コマンドブラウザ

コマンドブラウザは、ドラゴンスピーチによって認識される音声コマンド(ソフトウェアに用意されているコマンドのほか、ユーザーまたはシステム管理者がカスタムコマンドとして追加できるものも含みます) を検索できるウィンドウです。

  • コマンドブラウザで出来ること
  • コマンドの表示とトレーニング
  • コマンドの作成と変更
  • コマンドのインポートとエクスポート
  • カスタムコマンドの適用範囲の変更

コマンドブラウザを開く

「コマンドブラウザを開く」または「コマンドブラウザを表示」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします。

  • グローバルコマンド

コマンドブラウザを初めて開いたときには、すべてのアプリケーションで使用できるグローバルコマンドのリストが表示されます。

コマンドの表示とトレーニング

特定の音声コマンドがいつも誤認識される場合は、そのコマンドの発音をうまく認識するようにドラゴンスピーチをトレーニングできます。

  • コマンドをトレーニングするには
1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
2. [アプリケーション] リストからコマンドのコンテキストを選択します。
3. トレーニングするコマンドを探し、選択します。
4. コマンドブラウザのタスクペインで、次のボタンのうち1つをクリックするか、ボタン名を言います。
・トレーニング
  選択したコマンドを今すぐトレーニングできます。表示される[単語のトレーニング] ダイアログボックスの指示に従ってください。
・後でトレーニング
  後でトレーニングをするために、[トレーニングリスト] のコマンドリストにコマンドを追加します。[後でトレーニング] を選択すると、[リストのトレーニング] ボタンが有効になります。
・リストのトレーニング
  トレーニングするコマンドのリストを含んだ[単語のトレーニング] ダイアログボックスを表示します。コマンドブラウザを閉じるときに、まだトレーニングされていないコマンドが[トレーニングリスト] にある場合は、
  終了前にそれらのコマンをトレーニングするかどうかの確認メッセージが表示されます。

コマンドの作成と変更

  • カスタムコマンド
    • カスタムコマンドとは、任意のアプリケーションでテキストの入力、画像の挿入、メニューのアクティブ化、コマンドのキー入力を行うために作成および変更できる音声コマンドです。ドラゴンスピーチには、いくつかのカスタムコマンドがあらかじめ用意されており、これをそのまま使用することも、ユーザーのニーズに合わせて変更することもできます。
  • カスタムコマンドを表示するには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [スクリプト] ボタンをクリックします。カスタムコマンドを使用できるコマンド文法が表示されます。初期設定では、カスタムのグローバルコマンドが除外されています。
    3. 別のコマンド文法を表示するには、文法リストから1つを選択します。
    ※スクリプトエリアのコマンド名の横に表示される次の記号は、コマンドタイプを示しています。
    テキストと画像
     選択したテキストや画像を挿入するために使用できます。
    マクロの記録
     一連のマウス動作とキー入力を記録できます。
    ステップバイステップ
     アプリケーションを制御するメニューおよびキー入力のコマンドをアクティブにできます。
    アドバンススクリプト
     Microsoft VBAのようなプログラミング言語を利用して、コンピュータ上のあらゆる機能を音声コマンドで実行できるようにするコマンドをプログラミングできます。
  • 新しいコマンドを作成するには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [スクリプト] ボタンをクリックします。カスタムコマンドを使用できるコマンド文法が表示されます。初期設定では、カスタムのグローバルコマンドが除外されています。
    3. [新規] ボタンをクリックします。マイコマンドエディタが表示されます。このエディタを使用して、コマンドに名前を付けてプロパティを割り当てます。
    4. [保存] をクリックします。コマンドブラウザの文法リストに新しいコマンドが表示されます。
  • 既存のコマンドを変更するには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [スクリプト] ボタンをクリックします。カスタムコマンドを使用できるコマンド文法が表示されます。初期設定では、カスタムのグローバルコマンドが除外されています。
      文法リストを使用して、目的のコマンドが関連付けられているプログラムまたはコンテキストを選択します。初期設定の文法はグローバルコマンドです。
    3. 表示されるコマンドのリストから、変更するコマンドを選択します。
    4. [プレビュー] をクリックして、コマンドプレビューエリアを表示します。
    5. 次のボタンのどちらかをクリックします。
     編集
    	 現在のコマンドが表示された状態でマイコマンドエディタが開きます。このエディタを使用して、コマンドのプロパティを変更します。
     新規コピー
    	 現在のコマンドが一意の名前で表示された状態でマイコマンドエディタが開きます。たとえば、グローバルコマンドの「スリープに移行」を選択すると、新しいコピーは「スリープに移行2」という名前になります。
    	 このエディタを使用して、コマンドのプロパティを変更します。
  • 既存のコマンドを削除するには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [スクリプト] ボタンをクリックします。カスタムコマンドを使用できるコマンド文法が表示されます。初期設定では、カスタムのグローバルコマンドが除外されています。
    3. 文法リストを使用して、目的のコマンドが関連付けられているプログラムまたはコンテキストを選択します。
    4. 表示されるコマンドのリストから、削除するコマンドを選択します。
    5. [削除] をクリックします。
    6. [はい] をクリックして、コマンドの削除を承認します。コマンドブラウザからそのコマンドの表示が消えます。

コマンドのインポートとエクスポート

カスタムコマンドをファイルにエクスポートし、そのファイルを他のユーザーがインポートすると、カスタムコマンドを他のプロファイルと共有できます。コンピュータ上に複数のプロファイルがある場合でも、この方法を使用することで、どのプロファイルを現在開いているかに関係なく、カスタムコマンドにアクセスできるようになります。

  • コマンドファイルをインポートするには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [コマンド管理] ボタンをクリックします。
    3. [コマンド管理] タスクペインで、[インポート] をクリックします。
    4. [インポートするコマンドの選択] ダイアログボックスを使用して、インポートする音声コマンドファイル(例: My_Commands.dat) の場所に移動し、そのファイル名を選択します。
    5. [開く] をクリックします。
    6. 表示される[インポートするコマンドの選択] ダイアログボックスで、インポートするコマンドの左にあるチェックボックスをクリックし、チェックボックスにチェックマークを表示します。
       適用範囲順にコマンドを探す必要がある場合は、[グループの表示]ボックスの[適用範囲別] ラジオボタンをクリックし、プラス(+) 記号をクリックして、目的のリストを展開します。
    7. インポートするすべてのコマンドを選択したら、[インポート] ボタンをクリックします。
  • コマンドをエクスポートするには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [コマンド管理] ボタンをクリックします。
    3. グループリストを使用して、エクスポートするコマンドが含まれているコマンドグループを選択します。
    4. 必要に応じて、プラス(+) 記号をクリックしてコマンドのリストを展開し、エクスポートするコマンドを探します。
    5. エクスポートするすべてのコマンドについて、左側にあるチェックボックスをオンにして、チェックマークが表示された状態にします。
    6. タスクペインの[エクスポート] ボタンをクリックします。
    7. [エクスポートするコマンドの選択] ダイアログボックスでは、次の操作ができます。
    	・新しいファイル名を入力し、[保存] をクリックします。
    	・リストからファイル名を選択し、[保存] をクリックします。表示される[コマンドのエクスポート] ダイアログボックスで、[上書き]、[結合]、[キャンセル] のいずれかをクリックします。
    	[上書き] を選択すると、既存のファイルにあるコマンドが選択したコマンドで置き換えられます。[結合] を選択すると、選択したコマンドがファイル内の既存のコマンドに追加されます。

カスタムコマンドの適用範囲の変更

選択したコマンド群のグループや適用範囲を変更できます。

  • コマンドグループを変更するには
    1. コマンドブラウザを開きます(「コマンドブラウザ」と言うか、Dragonバーの[ツール]メニューで[コマンドブラウザ] をクリックします)。
    2. [コマンド管理] ボタンをクリックします。カスタムコマンドを使用できるグループが表示されます。
    3. オプションで、[グループ] ボックスをクリックして、コマンドのグループを表示します。マイコマンドエディタでカスタムコマンドを作成した場合は、それらのコマンドがユーザー定義グループに表示されます。
    4. 必要に応じてプラス(+) 記号をクリックして、コマンドを展開します。初期設定では、(すべて)、Dragon、サンプルの各グループが使用可能です。カスタムコマンドを作成すると、ユーザー定義もリストに表示されます。
    5. コマンド名の左にあるボックスをオンにして、変更する1つ以上のコマンドを選択します。コマンドを選択すると、そのボックスにチェックマークが表示されます。
    6. [プロパティの編集] をクリックして、[マイコマンドプロパティ] ダイアログボックスを開きます。
    7. [マイコマンドプロパティ] ダイアログボックスでは、次の操作ができます。
    	・コマンドを表示するコマンドグループを変更する。
    	・新しいグループを作成する。独自のグループを作成するには、グループ名を選択し、その状態で新しいグループ名をキーまたは音声で入力します。
    	・コマンドの適用範囲を変更する。
    8. 完了したら、[保存] をクリックします。

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2017-05-24 (水) 15:22:44 (363d)